Forum not providing backlink to linked websites

Discussion in 'Search Engine Optimization' started by saahil2310, Jun 5, 2014.

  1. saahil2310

    saahil2310
    uix_expand uix_collapse
    Member

    Joined:
    Jan 9, 2014
    Messages:
    145
    Likes Received:
    7
    Hello Webmasters,
    I have created a forum on pharmacy related discussions. This forum is running since two years now. It is indexed and crawled by Google several times. But the problem is that it is not providing a single backlink to the other linked websites in this forum. Users have profile homepages and signatures too. But my forum is not giving any backlink to them. This forum has been created with phpbb. Is there anything missing like any setting in ACP?
    This very problem is causing my forum users leaving my forum. Hopefully I will get help from my co webmasters. Thanks in advance for your valuable responses.
     
  2. ConsultJoseph

    ConsultJoseph
    uix_expand uix_collapse
    New Member

    Joined:
    Apr 25, 2014
    Messages:
    20
    Likes Received:
    2
    When you say there are not giving any backlink, are you saying that the links are not live? Or are you saying that Google is not indexing the pages where the links are found which mean the links do not count? Or do you mean that the links are all NOFOLLOWs as opposed to DOFOLLOWs which more backlink builders want?
     
  3. webpro

    webpro
    uix_expand uix_collapse
    New Member

    Joined:
    Jun 2, 2014
    Messages:
    13
    Likes Received:
    1
    There may be many factors like

    1) You are giving no-follow links
    2) your own website is not so powerful and links you are distributing are not getting much juice out of it .
    3) Links going out to be totally irrelevant and not related to forum theme i.e pharmacy
     
  4. paulsimmons

    paulsimmons
    uix_expand uix_collapse
    Member

    Joined:
    Apr 21, 2014
    Messages:
    60
    Likes Received:
    1
    Please share the URL if possible.
     
  5. Mark T

    Mark T
    uix_expand uix_collapse
    Active Member

    Joined:
    Dec 28, 2011
    Messages:
    1,201
    Likes Received:
    230
    As paulsimmons said, could you please share the URL of the forum you are pertaining to so members of BAF could check and analyze the problem.

    Thanks,
    Mark
     

Share This Page